Du bist nicht angemeldet. [Anmelden]
Optionen
Thema bewerten
appName nicht in appconfig - #2886272 - 24.01.2018, 13:58:49
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Moin,

im Dialog in dem man Apps installiert, steht bei mir in den grünen Buttons immer: "appName nicht in app.config".
Mag mir jemand sagen was falsch ist?
Ich hab habe appName in der app.config stehen:

Zitat:
appName = MeinAppName
appVersion = 1.0
mayBeInstalledBy.1 = Recaro.knuddelsDE
autoUpdate = false


Und sie liegt auch in /ftp/MeinAppName/


MfG

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Recaro] - #2886346 - 24.01.2018, 22:06:46
IgelchenM
​Laubhaufenbewohner

Registriert: 10.02.2005
Beiträge: 1.462
Ort: Bochum
Huhu Recaro,
ich hab es jetzt nicht getestet, könnte mir aber vorstellen, dass das ganze funktioniert, wenn du einen anderen appNamen einträgst.

So dass das Script verwirrt ist, dass sowohl appName als Vorgabe angegeben wird und zeitgleich im Namen enthalten ist. Benenne es doch mal um in "MeineApp". Wenn es danach immer noch nicht geht, geb am besten hier nochmal bescheid.
_________________________
Wo zum Teufel ist dieser Wayne wenn man ihn braucht?!

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: IgelchenM] - #2886355 - 25.01.2018, 00:53:35
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Hey IgelchenM,

Ich habe jetzt den Ordner in "Blubb" umbenannt und in der app.config stehen:

appName = MeineApp
appVersion = 1.0
mayBeInstalledBy.1 = Recaro.knuddelsDE
autoUpdate = false



Das Ergebnis ist nachwievor:



Ich mein die App funzt ganz normal, dennoch interessiert mich warum das da steht^^

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Recaro] - #2886387 - 25.01.2018, 12:10:24
Vampiric Desire
​ChannelMaster

Registriert: 15.09.2013
Beiträge: 1.689
sicher, dass deine datien alle in utf8 gespeichert sind?
_________________________
/apps install 30559674.ChannelMaster

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Vampiric Desire] - #2886422 - 25.01.2018, 17:54:05
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Moin Vampiric Desire,

Visual Studio Code sagt mir dass die Datei UTF-8 mit bom codiert gespeichert und geöffnet wird.
Öffne ich sie in notepad steht dort ebenfalls utf8. Ich denke das müsste passen.

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Recaro] - #2886491 - 26.01.2018, 01:45:34
Sunnyboyy17
​Stammchatter

Registriert: 15.03.2006
Beiträge: 2.699
Ort: Deutschland
Unabhängig davon hat er mir gestern seine appconfig gesendet gehabt.
Nachdem, ich sie auf dem DEV getestet habe, selbst mit dem Name den er mir nannte ging es, also denke ich liegt das Problem nicht an der config, sondern eher an der main.js (Vermutung)
_________________________
Der größte Feind der Qualität ist die Eile.
Suche nicht nach Fehlern, suche nach Lösungen.
Wer aufhört, besser zu werden, hat aufgehört, gut zu sein.

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Sunnyboyy17] - #2886530 - 26.01.2018, 10:29:36
DdvOiD
​Still lovin

Registriert: 24.02.2005
Beiträge: 640
Ort: Deutschland, NRW, Kempen
An der main.js kann es nicht liegen.
Wenn es aber ja (scheinbar) bei Sunnyboyy17 klappt (ohne die Datei zu verändern) - dann liegt der Fehler hier klar irgendwo im Ftp Bereich - Datei nicht hochgeladen, im falschen Ordner etc.
_________________________
Ich weiß ich bin ein A-loch... :-D , doch Scheiß egal ob ihr mich liebt... ICH hab mich gern :-]

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: DdvOiD] - #2886544 - 26.01.2018, 12:46:09
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Moin,

die Datei liegt im selben Ordner wie die main.js. Die App funktioniert auch wie sie soll, also ist es für mich mehr ein optischer Fehler, dass das im Button angezeigt wird.

Die Struktur:



Bearbeitet von Recaro (26.01.2018, 12:47:19)

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Recaro] - #2886546 - 26.01.2018, 12:50:57
Vampiric Desire
​ChannelMaster

Registriert: 15.09.2013
Beiträge: 1.689
Dann lies mal den AppNamen in der main.js aus und gib dem mal aus.
_________________________
/apps install 30559674.ChannelMaster

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Vampiric Desire] - #2886549 - 26.01.2018, 13:10:47
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Moin, habe ich mal gemacht:

Code:
App.chatCommands = {
    test123: function(user, params, command)
    {
        KnuddelsServer.getDefaultBotUser().sendPublicMessage('Appname=' + KnuddelsServer.getAppAccess().getOwnInstance().getAppInfo().getAppName());
    }
}


Nach Eingabe zeigt der Bot dann: Appname=null

Hmpf

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Recaro] - #2886554 - 26.01.2018, 13:35:06
Vampiric Desire
​ChannelMaster

Registriert: 15.09.2013
Beiträge: 1.689
Dann bleibe ich bei Kodierungsfail oder falscher Upload

1. Schau dir die Datei auf dem FTP mal an (app.config)
2. versuch es ohne bom (utf8)
3. Erstell die Datei komplett neu, eventuell sind da irgendwo whitespaces versteckt.


Bearbeitet von Vampiric Desire (26.01.2018, 13:35:25)
_________________________
/apps install 30559674.ChannelMaster

[zum Seitenanfang]  
Re: appName nicht in appconfig [Re: Vampiric Desire] - #2886556 - 26.01.2018, 14:05:39
Recaro
​Whiplasher

Registriert: 23.09.2013
Beiträge: 56
Ort: Hamburg
Moin Vampiric Desire,

das war die Lösung. ohne die BOM klappt es! (War der Meinung irgendwo mal gelesen zu haben, dass es sogar genau so gespeichert werden soll). Ich danke Dir und auch den anderen, fürs Schreiben.

[zum Seitenanfang]